build.gradle 1.25 KB
Newer Older
1
apply plugin: 'java'
2 3
sourceCompatibility = 1.8
targetCompatibility = 1.8
akwizgran's avatar
akwizgran committed
4

5 6
apply plugin: 'net.ltgt.apt'
apply plugin: 'idea'
akwizgran's avatar
akwizgran committed
7 8 9
apply plugin: 'witness'

dependencies {
10
	compile project(path: ':bramble-api', configuration: 'default')
akwizgran's avatar
akwizgran committed
11
	compile 'com.madgag.spongycastle:core:1.58.0.0'
akwizgran's avatar
akwizgran committed
12
	compile 'com.h2database:h2:1.4.192' // This is the last version that supports Java 1.6
13
	compile 'org.bitlet:weupnp:0.1.4'
14

15 16
	apt 'com.google.dagger:dagger-compiler:2.0.2'

17
	testCompile project(path: ':bramble-api', configuration: 'testOutput')
18 19

	testApt 'com.google.dagger:dagger-compiler:2.0.2'
akwizgran's avatar
akwizgran committed
20 21 22 23
}

dependencyVerification {
	verify = [
akwizgran's avatar
akwizgran committed
24
			'com.madgag.spongycastle:core:199617dd5698c5a9312b898c0a4cec7ce9dd8649d07f65d91629f58229d72728',
akwizgran's avatar
akwizgran committed
25
			'com.h2database:h2:225b22e9857235c46c93861410b60b8c81c10dc8985f4faf188985ba5445126c',
26
			'org.bitlet:weupnp:88df7e6504929d00bdb832863761385c68ab92af945b04f0770b126270a444fb',
akwizgran's avatar
akwizgran committed
27 28
	]
}
29 30 31 32 33

// needed to make test output available to bramble-j2se
configurations {
	testOutput.extendsFrom(testCompile)
}
34
task jarTest(type: Jar, dependsOn: testClasses) {
35 36 37 38 39 40
	from sourceSets.test.output
	classifier = 'test'
}
artifacts {
	testOutput jarTest
}
41 42 43

// If a Java 6 JRE is available, check we're not using any Java 7 or 8 APIs
tasks.withType(JavaCompile) {
44
	useJava6StandardLibrary(it)
45
}