[briar-headless] update dependencies

parent 51209b5e
Pipeline #2606 passed with stage
in 10 minutes and 54 seconds
plugins { plugins {
id 'java' id 'java'
id 'idea' id 'idea'
id 'org.jetbrains.kotlin.jvm' version '1.2.70' id 'org.jetbrains.kotlin.jvm' version '1.2.71'
id 'org.jetbrains.kotlin.kapt' version '1.2.70' id 'org.jetbrains.kotlin.kapt' version '1.2.71'
id 'witness' id 'witness'
} }
apply from: 'witness.gradle' apply from: 'witness.gradle'
...@@ -14,9 +14,9 @@ dependencies { ...@@ -14,9 +14,9 @@ dependencies {
implementation project(path: ':briar-core', configuration: 'default') implementation project(path: ':briar-core', configuration: 'default')
implementation project(path: ':bramble-java', configuration: 'default') implementation project(path: ':bramble-java', configuration: 'default')
implementation 'io.javalin:javalin:2.2.0' implementation 'io.javalin:javalin:2.3.0'
implementation 'org.slf4j:slf4j-simple:1.7.25' implementation 'org.slf4j:slf4j-simple:1.7.25'
implementation 'com.fasterxml.jackson.core:jackson-databind:2.9.6' implementation 'com.fasterxml.jackson.core:jackson-databind:2.9.7'
implementation 'com.github.ajalt:clikt:1.5.0' implementation 'com.github.ajalt:clikt:1.5.0'
kapt 'com.google.dagger:dagger-compiler:2.0.2' kapt 'com.google.dagger:dagger-compiler:2.0.2'
...@@ -24,11 +24,11 @@ dependencies { ...@@ -24,11 +24,11 @@ dependencies {
testImplementation project(path: ':bramble-api', configuration: 'testOutput') testImplementation project(path: ':bramble-api', configuration: 'testOutput')
testImplementation project(path: ':bramble-core', configuration: 'testOutput') testImplementation project(path: ':bramble-core', configuration: 'testOutput')
def junitVersion = '5.2.0' def junitVersion = '5.3.1'
testImplementation "org.junit.jupiter:junit-jupiter-api:$junitVersion" testImplementation "org.junit.jupiter:junit-jupiter-api:$junitVersion"
testImplementation "org.junit.jupiter:junit-jupiter-params:$junitVersion" testImplementation "org.junit.jupiter:junit-jupiter-params:$junitVersion"
testRuntime "org.junit.jupiter:junit-jupiter-engine:$junitVersion" testRuntime "org.junit.jupiter:junit-jupiter-engine:$junitVersion"
testImplementation "io.mockk:mockk:1.8.6" testImplementation "io.mockk:mockk:1.8.9"
testImplementation "org.skyscreamer:jsonassert:1.5.0" testImplementation "org.skyscreamer:jsonassert:1.5.0"
} }
......
This diff is collapsed.
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment