build.gradle 1.49 KB
Newer Older
1
apply plugin: 'java-library'
2 3
sourceCompatibility = 1.8
targetCompatibility = 1.8
akwizgran's avatar
akwizgran committed
4

5
apply plugin: 'ru.vyarus.animalsniffer'
6 7
apply plugin: 'net.ltgt.apt'
apply plugin: 'idea'
akwizgran's avatar
akwizgran committed
8
apply plugin: 'witness'
9
apply from: 'witness.gradle'
akwizgran's avatar
akwizgran committed
10 11

dependencies {
12 13
	implementation project(path: ':bramble-api', configuration: 'default')
	implementation 'com.madgag.spongycastle:core:1.58.0.0'
14
	implementation 'com.h2database:h2:1.4.192' // The last version that supports Java 1.6
15
	implementation 'org.bitlet:weupnp:0.1.4'
16
	implementation 'net.i2p.crypto:eddsa:0.2.0'
akwizgran's avatar
akwizgran committed
17
	implementation 'org.whispersystems:curve25519-java:0.4.1'
18
	implementation 'org.briarproject:jtorctl:0.3'
19

20 21
	apt 'com.google.dagger:dagger-compiler:2.0.2'

22
	testImplementation project(path: ':bramble-api', configuration: 'testOutput')
23
	testImplementation 'org.hsqldb:hsqldb:2.3.5' // The last version that supports Java 1.6
24 25 26 27 28 29
	testImplementation 'junit:junit:4.12'
	testImplementation "org.jmock:jmock:2.8.2"
	testImplementation "org.jmock:jmock-junit4:2.8.2"
	testImplementation "org.jmock:jmock-legacy:2.8.2"
	testImplementation "org.hamcrest:hamcrest-library:1.3"
	testImplementation "org.hamcrest:hamcrest-core:1.3"
30 31

	testApt 'com.google.dagger:dagger-compiler:2.0.2'
32 33

	signature 'org.codehaus.mojo.signature:java16:1.1@signature'
akwizgran's avatar
akwizgran committed
34 35
}

36
// needed to make test output available to bramble-java
37 38 39
configurations {
	testOutput.extendsFrom(testCompile)
}
40
task jarTest(type: Jar, dependsOn: testClasses) {
41 42 43 44 45 46
	from sourceSets.test.output
	classifier = 'test'
}
artifacts {
	testOutput jarTest
}